手动更新glibc后,系统语言环境异常

因为程序需要glibc-2.14,但是centOS6.5系统只有2.12的rpm包。去官网下了个glibc-2.14的tar包,并且建立软连接后,程序可以正常运行,但是不能设置语言了。因为有些程序需要读中文目录,所以这个语言还是要修改的。
每次登陆终端都会报这个错
google上搜了下说是缺少glibc-common包,但是没有找到2.14版本的,手动下载了2.14版本的rpm包安装之后也不行。



把glibc升级到2.14,网上一抓一大把,粗制滥造的就算了,有很多篇很详细的文章,不过纵观全网大量的文章居然都漏了一个重要步骤,直接就导致了后面locale的设置问题。大部分教程make&;&;makeinstall完成后,直接开始设置软连接,设置完以后文章就结束了!然后你以为就没事了吗?
VI编辑器打开日志,各种^M 各种口口口,各种乱码~~
千辛万苦最后才知道,拜托make完还要make localedata好伐!!


make localedata/install-locales 
终于,打开服务器不报错了,vi也正常了。。。重要的事情说三遍 
make localedata/install-locales 
make localedata/install-locales 
make localedata/install-locales

来源: https://bbs.csdn.net/topics/391069999#new_post   

评论

    Error (#32) - KOKO.VC

    Error (#32)

    An internal server error occurred.

    The above error occurred while the Web server was processing your request.

    Please contact us if you think this is a server error. Thank you.