TIP: glibc

记glibc升级失败后的恢复

  • 1791

glibc是linux的基础运行环境,绝大多数的命令都要依赖glibc,一旦升级出错,将是灾难性的。glibc环境异常,就别想远程连接服务器,只能依靠本地使用引导光盘修复。特别是对于云服务器来说,没有实体机,这glibc环境崩溃,基本服务器就可以格式化重装了。现在想想,真是后怕,当时真是胆大,直接就照着教程开撸。


手动更新glibc后,系统语言环境异常

  • 414

因为程序需要glibc-2.14,但是centOS6.5系统只有2.12的rpm包。去官网下了个glibc-2.14的tar包,并且建立软连接后,程序可以正常运行,但是不能设置语言了。每次进入终端都提示cannot change locale(zh_cn.utf-8):no such file or directory


Error (#32) - KOKO.VC

Error (#32)

An internal server error occurred.

The above error occurred while the Web server was processing your request.

Please contact us if you think this is a server error. Thank you.